Linux – Klarmobil USB XS Stick P14 von 4G Systems (Vodafone.de) mini howto

USB XS Stick P14 von 4G Systems
http://4g-systems.com/produkte/xsstick/xsstickrp14.html
Linux: Debian 6/7

Instalation usb-modeswitch und wvdial

überprüfung der USB Ports mit lsusb

der Stick ist in diesem Fall auf USB3.
/dev/ttyUSB3 (Bus 001 Device 003: ID 1c9e:9605 OMEGA TECHNOLOGY)
Damit der Stick richtig erkannt wird, empfehlt sich folgender Eintrag in der /etc/rc.local

Alternativ kann man auch den USB Treiber über  Module laden

PPP Eintrag zu den üblichen Netzwerkeinstellung in der /etc/network/interfaces

Installation von wvdial mit apt-get install wvdial die config von wvdial  /etc/wvdial.conf

Mein Router befindet sich in der nähe der Landesgrenze.
Um eventuelle Roaming Gebühren zu vermeiden lege ich den Netzbetreiber mit
Init4 = AT+COPS=1,0,“Vodafone.de“ fest.  Man kann auch mit AT+COPS? automatisch den Netzbetreiber auswählen. Die Karten-PIN habe ich vorher am Telefon entfernt,dies minimiert die Fehlerquote beim Skript.  Weitere Infos und  AT Befehle findet man in Google oder in den Links am ende vom Beitrag.

Fertig !

Anhang:
Da ich den Rechner als Router am laufen habe , habe ich entsprechende Filterregeln in /etc/iptables.sh

Weitere Infos zu Einrichtung eines DHCP u.s.w hier

Interessante Links zum Thema:
http://john.de-graaff.net/wiki/doku.php/links/umts_debian
http://www.surf-stick.net/apn-einstellungen.html
http://www.silef.de/2010/06/25/klarmobil-xssurfstick-w14-mit-ubuntu-10-04/
http://wiki.sakis3g.org/wiki/index.php?title=Sakis3G_configuration
http://john.de-graaff.net/wiki/doku.php/links/umts_debian
http://www.kammerath.net/linux-surfstick.html
https://wiki.archlinux.de/title/Surfstick_einrichten
http://www.activexperts.com/sms-component/at/etsi/
http://m2msupport.net/m2msupport/atcops-plmn-selection/
http://www.nobbi.com/atgsm.html
http://wiki.ubuntuusers.de/XS_Stick_W14

Fehler:
1.) „.. sb_modeswitch segfault at 0 ip ..“
Usb Stick wird nicht als Modem erkannt , wie oben lsusb und die Modem Module laden. z.B

2.) „Sending: ATDT*99***1#
–> Waiting for carrier.
ATDT*99***1#
ERROR
–> Invalid dial command.“

Manchmal häng sich das Modem auf, am besten einmal  die AT Befehle ins Leere laufen lassen in dem man nicht benutzen USB port (z.B. /dev/ttyUSB0) in der wvdial.conf angibt und in das Programm wvdial in der Konsole ausführt.

Nach einem Upgrade von Debian Wheezy , keine Netzwerkverbindung mehr

Nach einem Upgrade von Debian Wheezy , keine Netzwerkverbindung mehr vorhanden. Das Netzwerk Device existiert und es wird auch eine IP von DHCP Server zugeteilt.
Auch bei Einstellungen der iP in /etc/network/interfaces sowie der DNS Server,scheint alles richtig zu sein.
Doch die Verbindung nach außen will einfach nicht klappen. Schuld war in meinem Fall der Network-Manager.

Ich brauch ihn nicht, deswegen sofort „Weg“ mit dem.

Und schon geht alles wieder.